ATV wont stay running - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 03-18-2017, 02:08 PM Thread Starter
Junior Member
 
Join Date: Mar 2017
Posts: 1
ATV wont stay running

so here is my problem, i have a 95 Kawasaki Mojave, i bought a rebuild kit for the carb, set the air fuel mixture(i hope is right) to the factory setting(what is shown in the book) but i'm still having problems with it staying running after i start it(kick start only) and it only stays running with the choke on and and when i keep giving it gas, and when i have it running i can only go half throttle or so, once i turn the choke off or stop giving it gas....It dies...i have called dealers and they wont tell me a **** thing..so i really need help..thanks
contryboyy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome