Mule 2510 Rear cylinder - no spark - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 06-24-2019, 01:41 AM Thread Starter
Junior Member
 
Join Date: Apr 2015
Posts: 5
Mule 2510 Rear cylinder - no spark

I have no spark on the rear cylinder of my 2510 mule. I have replaced the coil and the plug on that cylinder with new parts. Still no change. I have looked at fuses and most of the wiring and dont see any issues there.

Im not well versed on igniters - will a bad igniter let is spark on one cylinder and not the other?

What other troubleshooting would help? I have the service manual but it isnt very easy for me to find other troubleshooting steps.

Thanks!
thegriffiths is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-27-2019, 08:06 AM
Senior Member
BTK Expert
 
Join Date: Apr 2009
Posts: 862
it can but it's more likely a problem with the pickup coil than the ignitor.
imported_cookie_monster is offline  
post #3 of 5 (permalink) Old 06-27-2019, 09:35 AM Thread Starter
Junior Member
 
Join Date: Apr 2015
Posts: 5
Thanks for the help. I will try that next then and post my results.
thegriffiths is offline  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 07-11-2019, 05:20 PM Thread Starter
Junior Member
 
Join Date: Apr 2015
Posts: 5
Is there a way to test the pickup coil? I am back in my garage finally to work on the mule and I can take it off pretty easily - but instead of just buying a new one first, I want to test the old one.

Thanks!
thegriffiths is offline  
post #5 of 5 (permalink) Old 08-18-2019, 08:19 PM Thread Starter
Junior Member
 
Join Date: Apr 2015
Posts: 5
So I was able to test the coils and they were ok. I rolled the dice and ordered an igniter and my mule started on the first try. Now on to fixing the overheating problem - pretty sure its a leak at the radiator. Thanks for the advice, I learned how to test the coils and know more about my engine now.
thegriffiths is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome