Speedo clears when a backfire occurs - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 08-27-2016, 01:35 PM Thread Starter
Junior Member
 
Join Date: Aug 2016
Posts: 2
Speedo clears when a backfire occurs

I have a 2007 Vulcan 2000, recently when starting, or after a stall and I restart it will backfire and clear out the odometer trip reading and reset the clock to 12:00. The local shop here is stumped. Has anyone had this happen and what is the cure. Does not happen often but am afraid she will let me down some where. Thnx
AKY2K is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-29-2016, 11:21 AM
Administrator
BTK Intermediate
 
administrator's Avatar
 
Join Date: Dec 2004
Location: Toronto, ON
Posts: 245
Hey there,

The Help and Suggestion forum is meant for site related issues and inquiries.
I have moved your thread to a more suitable section.

I hope you find the answer you are looking for.

Enjoy the site!

Richard.
administrator is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome