2018 Mule SX Oil issue - Kawasaki Motorcycle Forums
 
LinkBack Thread Tools
post #1 of 7 (permalink) Old 01-27-2019, 11:05 AM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 6
2018 Mule SX Oil issue

My mule has 50 hours on it and the oil filler cap keeps popping off and spewing oil all over the engine. Help.
royliljequist is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-29-2019, 10:58 AM
Member
BTK Beginner
 
Join Date: Oct 2018
Location: New Brunswick, Canada
Posts: 60
Ok, I assume you have inspected the cap and its seat carefully to make sure they are not the cause.


If they are ok, then you must have excessive pressure in the crankcase. Is it possible you have overfilled the oil?
Check your PCV and any other crankcase breather hoses to make sure they are operating normally.


But with only 50 hours, is not still under warranty? If so have your dealer check it out.
WFO-KZ is offline  
post #3 of 7 (permalink) Old 01-29-2019, 12:00 PM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 6
yeah, Thanks. I checked oil cap thinking I didn't push it down good enough but it is still under warranty so yes I'm thinking I should bring it in.
royliljequist is offline  
Sponsored Links
Advertisement
 
post #4 of 7 (permalink) Old 01-30-2019, 11:52 AM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 6
A Kawasaki mechanic told me it is the oil pressure relief valve hose. He said it is a common problem. It gets moisture in it and then it freezes and the pressure will find a place to go so it pops off the oil cap. Spewing oil everywhere.
I would think Kawasaki would remedy this. Now its just a matter of locating it. He told me but I'll have to call him back cause I'm still not sure where to find the hose.
royliljequist is offline  
post #5 of 7 (permalink) Old 02-28-2019, 11:14 AM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 6
Apparently is is not a warranty issue. Instead of a update they call it a upgrade. Therefore I paid for it. I just have to crawl under the machine and drain the reservoir when I see fluid builds up.
royliljequist is offline  
post #6 of 7 (permalink) Old 03-23-2019, 10:57 AM Thread Starter
Junior Member
 
Join Date: Jan 2019
Posts: 6
surprised

I have a 2018 mule sx and I'm surprised no one ever addressed this issue. It is a common problem that the pressure relief hose that redirects the emissions back to the engine freezes inside because of moisture build up then pops off the oil cap send oil all over the place. I had a authorized Kawasaki dealer put a upgrade in the line and now I have no problem. The only inconvenient I have now is I have to pull the little reservoir off and drain the water(below freezing). Every brand has their quirks. Is this a Kawasaki thing or is it common for a lot of side by sides?
royliljequist is offline  
post #7 of 7 (permalink) Old 03-26-2019, 04:08 PM
Member
BTK Beginner
 
Join Date: Oct 2018
Location: New Brunswick, Canada
Posts: 60
Glad to hear you got it sorted.


I have owned a 2007 Kawi Brute Force 650 for 10 years and now own a 2018 Brute Force 750. Neither has ever given me any problems at all, and I do lots of cold winter driving. So it sounds like its a Mule problem. Too bad it was not under warranty. You could try writing to Kawasaki to complain.
WFO-KZ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kawasaki Motorcycle Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome