Kawasaki Motorcycle Forums - Search Results
Advanced Search
Showing results 1 to 8 of 8
Search took 0.02 seconds.
Search: Posts Made By: Freddielg
Forum: Kawasaki Cruisers   07-27-2019, 03:29 PM
Replies: 0
Views: 141
Posted By Freddielg
Muffler question

I have a 2003 Vulcan 1600 Classic.I have a rattle in one of my mufflers..Maybe either rusted out or loose baffle..Would this cause my engine to over heat and is it safe to ride without causing any...
Forum: Kawasaki Cruisers   06-09-2019, 01:21 AM
Replies: 5
Views: 236
Posted By Freddielg
Thanks for the advice guys..

Thanks for the advice guys..
Forum: Kawasaki Cruisers   06-03-2019, 03:00 PM
Replies: 5
Views: 236
Posted By Freddielg
Thanks for the info...That's probably what I'll...

Thanks for the info...That's probably what I'll end up having to do..Sure would love for it to work properly though..
Forum: Kawasaki Cruisers   06-01-2019, 02:06 PM
Replies: 5
Views: 236
Posted By Freddielg
digital gas Gage not accurate

I have a 2003 Vulcan 1600 Classic..I noticed that there are only a few "bars" showing..I have at least a half a tank of gas in it,maybe more..Any ideas of how I can get my gage to show an accurate...
Forum: Kawasaki Cruisers   05-28-2019, 01:52 AM
Replies: 4
Views: 250
Posted By Freddielg
Thanks for the replies..I found my problem...It...

Thanks for the replies..I found my problem...It was in the switch on the handle bar..Seems somehow a dirt dobber got inside the housing and filled it up with dirt..A little cleaning, a little lightly...
Forum: Kawasaki Cruisers   05-25-2019, 02:42 PM
Replies: 4
Views: 250
Posted By Freddielg
How do I test the turn signal relay?

How do I test the turn signal relay?
Forum: Kawasaki Cruisers   05-25-2019, 01:08 PM
Replies: 4
Views: 250
Posted By Freddielg
I did..Test light shows I'm not getting and juice...

I did..Test light shows I'm not getting and juice to the rear right side..
Forum: Kawasaki Cruisers   05-25-2019, 12:35 AM
Replies: 4
Views: 250
Posted By Freddielg
Electrical Problem

Hi.Hope someone can help..I have a 2003 Vulcan 1600 Classic..My problem is. I have no rear " tail lights" nor a turn signal on the right side either front or back. Headlight and front "running...
Showing results 1 to 8 of 8

 
Forum Jump
 
For the best viewing experience please update your browser to Google Chrome