Kawasaki Motorcycle Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Hello,

I bought (2) 1982 kd80's together a month ago... One runs and is restored - the other was a parts bike but it's not missing that many parts so I'm trying to get it restored and running also. The main missing pieces are an ignition coil, levers, carb float, engine cover for carb, sprocket and chain. I've been successful finding most parts on ebay but not the carb cover - If any has a lead for a good used one (inexpensive) - please let me know...

As for the clutch - I don't know much about bikes/transmissions in general - I'm new to dirt bikes..Always been a car and boat guy. I believe the transmission is intact ( I see gears through the oil fill plug) and the clutch actuator is there - but shouldn't it feel spring loaded? It just turns in and out with no spring tension... I plan to swap over the coil from my other bike to start the engine then see if it goes through the gears - but I question if it will work with the clutch like this... I have been looking on kawasakipartsnation.com and beartooth kawi to see the exploded view and it doesn't look as easy as I hoped... Anyone experienced with what might be causing this? ( I'm ready for the question, "are you sure the clutch is inside and not removed for parts"...) - The answer is "no" I'm not sure of that but if I had to guess at this point I'd say it's all there - Other parts were stripped from it but the engine looks unmolested -lol.
 

·
Registered
Joined
·
407 Posts
Hello,

I bought (2) 1982 kd80's together a month ago... One runs and is restored - the other was a parts bike but it's not missing that many parts so I'm trying to get it restored and running also. The main missing pieces are an ignition coil, levers, carb float, engine cover for carb, sprocket and chain. I've been successful finding most parts on ebay but not the carb cover - If any has a lead for a good used one (inexpensive) - please let me know...

As for the clutch - I don't know much about bikes/transmissions in general - I'm new to dirt bikes..Always been a car and boat guy. I believe the transmission is intact ( I see gears through the oil fill plug) and the clutch actuator is there - but shouldn't it feel spring loaded? It just turns in and out with no spring tension... I plan to swap over the coil from my other bike to start the engine then see if it goes through the gears - but I question if it will work with the clutch like this... I have been looking on kawasakipartsnation.com and beartooth kawi to see the exploded view and it doesn't look as easy as I hoped... Anyone experienced with what might be causing this? ( I'm ready for the question, "are you sure the clutch is inside and not removed for parts"...) - The answer is "no" I'm not sure of that but if I had to guess at this point I'd say it's all there - Other parts were stripped from it but the engine looks unmolested -lol.
Deleted post, incorrect information.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·

Your diagram looks slightly different than what I've found for the kd80 M3...
However I can see the parts you pointed out would transfer spring tension to the clutch release. Mine looks like the one above. Is it possible that the mechanism is stuck and it may work once the engine is running? Man, I am really banking on some lame possibilities!
 

·
Registered
Joined
·
407 Posts

Your diagram looks slightly different than what I've found for the kd80 M3...
However I can see the parts you pointed out would transfer spring tension to the clutch release. Mine looks like the one above. Is it possible that the mechanism is stuck and it may work once the engine is running? Man, I am really banking on some lame possibilities!
Sorry, fo some reason, I thought you said you had a KDX80, not a KD. The KD clutch actuation system is more elaborate, than the KDX. 1st step, Pull off the clutch cover, and determine where the pushing motion ends, and at what component. Assembly # 13231 simply converts clutch arm rotation, into a pushing motion. Even ref #600 (small ball bearing) missing will cause your clutch to not apply pressure to part #13091. Post pics of your bike, and i'm sure we can figure it out.

Rich
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
Thanks, I'll be getting into it this week - I was away hunting last week.
I just got the service manual I ordered on ebay so hopefully that will help also.
I appreciate the reply!
 
1 - 5 of 5 Posts
Top