Kawasaki Motorcycle Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
1983 Spectre 1100D have to turn petcock to reserve at around 30mi even though plenty of fuel in tank? Any ideas? Gas gauge seems to read low as well around 1/2 tank at approx 30 mi. Only issue i have. Anyone else see this issue? I am thinking petcock assembly may be faulty...just a hunch. Thanks in advance!
 

·
Registered
Joined
·
1,392 Posts
I recommend you remove the tank, clean it out, and remove the petcock and make sure it's clean. The petcock may need to be rebuilt. I was able to still get a kit to rebuild mine in the 85ZN700 a couple years ago.
 

·
Registered
Joined
·
1,392 Posts
Oh, install a fuel filter before the carbs. That was one of the first things I did to my ZN700. Make sure it is a free flowing filter or it won't flow enough full for high throttle.
 

·
Queasy Rider
Joined
·
2,079 Posts
My guess is either a leaking diaphragm in the petcock or a vacuum hose leak to the carbs.
When I first bought my ZN1100, I was going through petcock kits twice a year until I discovered two things. 1, Cheap rebuild kits are just that. It's K&N or OEM only for me. 2. ETHANOL!!!!!Stay away from it. It will deteriorate rubber componants like the petcock and carburetor seals remarkably fast.
 

·
Queasy Rider
Joined
·
2,079 Posts
My guess is either a leaking diaphragm in the petcock or a vacuum hose leak to the carbs.
When I first bought my ZN1100, I was going through petcock kits twice a year until I discovered two things. 1, Cheap rebuild kits are just that. It's K&N or OEM only for me. 2. ETHANOL!!!!!Stay away from it. It will deteriorate rubber components like the petcock and carburetor seals remarkably fast. My petcock rubber has been holding up for years since I started doing those 2 things.
 

·
itching to ride
Joined
·
2,226 Posts
My guess is either a leaking diaphragm in the petcock or a vacuum hose leak to the carbs.
When I first bought my ZN1100, I was going through petcock kits twice a year until I discovered two things. 1, Cheap rebuild kits are just that. It's K&N or OEM only for me. 2. ETHANOL!!!!!Stay away from it. It will deteriorate rubber componants like the petcock and carburetor seals remarkably fast.
I recently started using non ethanol in my '91 S-10 and it gets much better mileage now. When I had my GPz 750 switching to non ethanol boosted my mileage from 50 to 55 and my rpms 200-300. I had to adjust idle downwards a couple hundred at least. It is garbage in these older fuel systems.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #9
Copy all. I only use Non-Ethanol and have adjusted the idle but the issue is not gas mileage, as the tank appears 90% full when I have to switch to reserve. I have a new petcock on order and hopefully this will solve this mystery. Thanks for your inputs though Brother!
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
My guess is either a leaking diaphragm in the petcock or a vacuum hose leak to the carbs.
When I first bought my ZN1100, I was going through petcock kits twice a year until I discovered two things. 1, Cheap rebuild kits are just that. It's K&N or OEM only for me. 2. ETHANOL!!!!!Stay away from it. It will deteriorate rubber componants like the petcock and carburetor seals remarkably fast.
Hoyt, You may have NAILED it! I did find a vacuum leak going to the carbs as the hose was only secured by the wimpy spring-type clamp. I replaced it with a Actual hose clamp and the bike even runs much better. I will see what happens when I run her down with fuel now. THANKS AGAIN!!!
 
1 - 12 of 12 Posts
Top