Kawasaki Motorcycle Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #1
Just signed up after lurking for a while.Excellent site!! Well I picked up a '81 750 LTD and have been working on it as time allows.I got carb kits from Z1 and I don't understand why the pilot mixture screws won't go in as far as the old ones did.oring,washer,spring and when I insert into the carb I can only get 2 turns before it bottoms.Old mixture screws or my new screws do the same thing.There doesn't seem to be any tension on the springs either.All old orings and washers came out of the carbs.I'm confused:confused: This bike runs great after 3000 rpm or so and Georges coil mod definetly woke it up.It runs rich the way it is now -bogs at low rpm,takes a while to warm up,but it really cranks after 3 or 4 thousand.I'll have a look tommorow-it's gotta' be somethin' stupid:oops: Anyone got any info on these Keihins? Thanks
 

·
Registered
Joined
·
1,512 Posts
I had a rotten o ring on mine and bits of it had gotten pushed into the opening the pilot screw went into. If this is only happening on one carb I'd say there's something in there, also because old and new screws aren't going in.

I used a twist tie with the paper stripped off to very carefully remove it.

Are you sure you're using the right spring?
 

·
Registered
Joined
·
37 Posts
Discussion Starter #3
I just put some moly(anti-sieze) on them and all 4 went in pretty easy.Just got back from a fast paced run!! Still has a bog on low rpm and idle doesn't come back down too quickly.It's getting there.Thanks,C.C.
 
1 - 3 of 3 Posts
Top