Kawasaki Motorcycle Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
Just got this bike, also have a 78 KZ650B, which was neglected for years. The Spectre hasnt been on the road in 2Yrs. Both have had electrical problems coming from corrosion on connectors. Have found all except for the spectre's. Its tail light is not working (brakelight is) horn is out, speedo and tach lights arent working, front running lights and fuel gauge arent working, either. I have cleaned every connector I have found, the fuses ohm out. Any ideas?
 

·
AZ's Official Mechanic
Joined
·
5,201 Posts
im betting alot of those lights are on the same circuit. sounds llike you have a wire broken inside the sheathing where you cant see it. might want to do some continuity tests on the wiring to see where the power stops. youll need some electrical schematics.
good luck :wink:
 

·
Registered
Joined
·
116 Posts
Discussion Starter #3
Thanks, I didnt think about that one. Ive got the clymers, which is a pretty good manual. I love this bike, Its 20 degrees in Boston and I cant get off my bike. That will keep me busy this weekend.
 

·
cptmatt
Joined
·
4 Posts
I now (or will have in a few weeks) a 1982 Spectre. What should I look for in renovating the bike. It currently doesn't start, but the motor turns, its been garaged, everything is where it should be, etc.
Are there ubiquitous seals, bearings, or peripheral parts that tend to be problematic, i.e. electrical shorts, sticky clutches, etc?

Also, what are some standard upgrades that seem to be popular? Will be using this as more of a sporty tourer than as a cruiser.

Thanks.
 

·
Registered
Joined
·
105 Posts
Re: -

jono, a twelve volt test light would work wonders in your situation. clip it to negative on battery and work your way down the positive side of the circuit till the light goes dead. look for corroded or broken connection between last good point and first bad one.
 
1 - 8 of 8 Posts
Top