Kawasaki Motorcycle Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
537 Posts
Discussion Starter · #1 ·
What do I have to do to make my 88 zx10 run good?Stock cv carbs,vance & hines ss2 header and exhaust.It bogs down at 4k rpm?Thanks,Steve.
 

·
AZ's Official Mechanic
Joined
·
5,201 Posts
try raising the needle first since its a midrange thing. does it have a jet kit in it that you know of ? if not you will need to do a jet kit to compensate for the exhaust. are you gonna run the stage 3 kit w/ individual air filters ?
 

·
Registered
Joined
·
537 Posts
Discussion Starter · #3 ·
I just put this bike on the rd.It was a rebuild.I noticed it was burning up plugs.I changed the jets to 135.I had spares.They probably are not right.

I wil get a jet kit stage 3,yes ,K&N individual air pods.

Can't I just by 130 jets,then raise the existing needle?
When you say raise the needle.Move the clip 1 notch lower,correct?
Thanks,Steve.
 

·
AZ's Official Mechanic
Joined
·
5,201 Posts
katmando said:
1. Can't I just by 130 jets,then raise the existing needle?

2. When you say raise the needle.Move the clip 1 notch lower,correct?
Thanks,Steve.

if you get a kit it will have directions on what they recommend and you cant compare kit jet sizes to stock oem jet sizes , they are determined differently between stock-oem and aftermarket.

yes to make it richer you would move the clip DOWN the needle (lifts the needle)
 

·
Registered
Joined
·
537 Posts
Discussion Starter · #6 ·
I raised the needle's.I was able to use the pods.Thanks.
Seems like there is to much gas getting to the plugs now that I am using 135 jets.I fouled out 2 sets of plugs.
I tried adjusting the air/fuel screw.It was out 2 turns.I moved it in 1 1/2.
That seemed to help.
When it starts it is missing on 1 cyl.I throttle it up and it fires on the 4th.
I also adjusted the butterfly ,2 turns out.
I took the plugs out.
3 are burning good.One is still getting to much gas.
I can smell it and I am going using more.There is gas in the lower bowels of the carb and carb boots.
Seems like it was running rich with the 135's.Then I was able to lean it out a little.It had 125's in the carbs.
At least it is starting right up and runs.Better than before.
Thanks for the help.
 

·
Registered
Joined
·
537 Posts
Discussion Starter · #9 ·
Should the throttle baffles be totally close in adjustment?Covering the real tiny jet holes?ThanksIf so I had the throttle baffles all out of wack!
 
1 - 10 of 10 Posts
Top