Kawasaki Motorcycle Forums banner

1 - 20 of 41 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I just bought a '89 300 Bayou - cheap... Doesn't run. In the process of cleaning it up and trying to figure out where to start. I notice its missing the regulator and the igniter. I guess these are pretty important judging by the prices Kawasaki is asking. :shock:

Any idea where to find these cheaper, used, etc...? Can I use one from another motorcyle, atv, etc...?

Here's the part numbers I need:
21119-1193 - Igniter
21066-1055 - regulator

This my 1st ATV and all and any help is greatly apprecieated!
 

·
Proud Owner Of This Forum & Beartooth Kawasaki
Joined
·
2,735 Posts
Welcome to the forum, the igniter would cost you $304.75 and the regulator would be $86.65 that is 15% off of retail I am not sure where you would find used. If you want to go new call Lauri at 1-800-556-3098 Beartooth Kawasaki
 

·
Registered
Joined
·
5 Posts
Hi, I don't know if you already got an igniter for the bayou or not yet, but I had the same problem with my '86 bayou 300. For the igniter, I used an ignition module from a GM car with eletronic ignition (H.E.I.). If you look at the module with the terminals pointing down, the two on the left go to the pickup coil (black and blue on my '86). The terminal on the lower right goes to power from the ignition switch (yellow/red on mine). The upper right terminal goes to the negative side of the coil (green/white on mine). Make sure to ground the module or it won't fire. The best way would be to mount it to a piece of 1/4" aluminum (for heat dissipation) and mount the plate to the frame. I've had mine hooked up for 2 months and haven't had a problem yet. The best part is the price. A new ignition module at Auto Zone is only $17 as opposed to the $350 that Kawasaki wanted for one (I don't even have that much into my bayou). I hope that helps.


Good luck
Mark
 

·
Registered
Joined
·
13 Posts
Thanks MKGearHead, You just saved me 300 bucks. My Igniter went out on my 01 300 Bayou and your fixed saved me from having to buy the Kawasaki one. Thanks Again Rob
 

·
Registered
Joined
·
1 Posts
interested to no

im interested to no if this will work on a 2001 bayou,
also theres 5 wires on the ignighter but your only using 4.
i would very much like to try this mod on my bayou 300
could you explane it a little more, year module to use, what to do with the extra wire, ect. when i bought this bayou it ran great for a week then quit and we have traced it to the ignighter, and theres no way i can afford 387.00 so any help on this will be greatfully thanked.
 

·
Registered
Joined
·
3 Posts
I just bought the GM ingitator and have not had a chance to try it. I do not know if I can used the wiring harness or will I have to run new wires? I will post the out come when I try it, hopely this weekend. Let me know if you find out anything.
Thanks
Rudy
 

·
Registered
Joined
·
3 Posts
Chevy ignition works on '86 Kawasaki 300 Bayou

Hey It works ! ! ! I bought an eletronic ignition (H.E.I.) for a 1988 Chevy Car part # EL102, brand name GP Sorensen from Advance Auto Parts. The module has 4 pronges W, G, B, & C. On my 1986 Kawasaki 300 Bayou, the black wire goes to the W, the blue wire goes to the G, the red/yellow wire goes to the B and the green/white wire goes to the C. Make sure you ground the module or it will not work. I have been riding my 4 wheeler this way for about a week (10 hours). There is also a resitor in the plug wire on mine. I'll be glad to send anyone pictures of mine if they need to see.
Thanks for all the help on here. I hope this helps someone else.

Rudy

P.S. I need a gas tank?
 

·
Registered
Joined
·
14 Posts
90 Klf 300 Fix

gotta say, thanks to all for your posts. My bayou had the same no start, changed the regulator and wired in an HEI module, and the old beast runs again!!! Once again, thanks to all, you saved me some decent change!!
 

·
Registered
Joined
·
1 Posts
Hi, new guy here,
I have an 85 185 bayou w/electric start with the same problem. Wondering if this would work for it also?
Thanks
 

·
Registered
Joined
·
16 Posts
Important update to the GM module...I have found that my timing is off after installing the module. I have gone back to a "high dollar" ignitor. Too bad...the module worked to get the spark back, but it doesn't have any way of controlling the timing advance. It seems to start and run with the timing fully advanced which causing back-firing into the intake. Oh well...it was worth a try.
 

·
Registered
Joined
·
2 Posts
Hello all, im new and the pickup coil went out on my '86 bayou 300 and i was wondering if anyone knew where i could get a used one fairly cheap. And i also need a stater if anyone knows where i could get one cheap.
 

·
Registered
Joined
·
13 Posts
allen, Did you find out your GM module didn't work after running it around awhile? Mine has been running great for awhile but know seems like it is jetted wrong. It starts up fine but dies as soon as I give it some gas. I can get it to rev out a bit by feathering the throttle and it pulls fine until I slow it down again to an idle. cleaned everything a couple of times and and it keep happening. Did yours do it the same way?
 

·
Registered
Joined
·
16 Posts
Yes, I did have to run it around for a while before it started acting up. Mine got to where it would hardly start, especially if you gave it any gas. Once started and wound up to a higher rpm, it would run great. This is how I concluded, with the help of a very good auto mechanic, that the timing is fully advanced all of the time. Good luck. I hope that this helps.
 

·
Registered
Joined
·
16 Posts
I would buy the regulator and install it with the new CDI. This is what was suggested to me by the vendor where I purchased my CDI. When I removed the old regulator, I found that it had a hole burned completely through it. I think this is what destroyed my CDI???!!!
 

·
Registered
Joined
·
1 Posts
87 Bayou Looking for CDI

Hello forum

I am looking for a CDI for my wife's 300 Bayou, and after reading the GM module posts,I am always looking for a alternative to shelling out huge $$

Has everyone had great success with this mod or has everyone had to swap out after time?

Cheers
Rick
 

·
Registered
Joined
·
5 Posts
Well, I've had mine in use for over 3 years and haven't had any problems (at least with the ignition). I usually ride at about 8000' , so the timing advance may actually help. Now my only problem is the fact that it smokes like a train and only has 50 psi compression. I guess it's time for a topend. As abused as it was when I got it, I'm surprised it lasted this long!
 
1 - 20 of 41 Posts
Top