Kawasaki Motorcycle Forums banner

1 - 7 of 7 Posts

·
_-=ShAd0vVfAx=-_
Joined
·
17 Posts
Discussion Starter #1
Has anyone ever seen a huge spark fly out from there i.c. igniter box. I started the bike the other day and it was running for a few minutes, then BAM, this huge spark flew from around the igniter box and the bike shut off. Then i went to turn the key back to the on position and the high beam lights on the LED screen would not light up. Every other light was on but the high beams and then the i.c. igniter box started smoking real bad. Does anyone have some insight on this issue ....
 

·
_-=ShAd0vVfAx=-_
Joined
·
17 Posts
Discussion Starter #4
So nobody knows why the box just blew up like that? It was strange, it was running one second then the igniter box just blew. I took it apart and the one big round part(maybe a diode????) was black along with some of the circuit board. Why would this happen? I saw three grounds on the bike, one on the motor, one to the battery, and one to the fuel pump fixture screw. Are there any missing that I just did not get?
 

·
Registered
Joined
·
4,807 Posts
Did you ever check for spark using the old screwdriver in the plug cap routine or trying to hold the plug up against the block?
There are lots of volts flying around in an ignition system and once in a while, if they have no where to go, they will weaken or damage a solid state component, that component will short itself out with smoke and fire the end result.
Not saying you did this, or that is what caused it, but I always recommend a spark tester properly connected to check the ignition system. They are cheap, eliminate any hair standing and are the easiest on the ignitor.

Sometimes, though, smoke happens!
 

·
_-=ShAd0vVfAx=-_
Joined
·
17 Posts
Discussion Starter #6
Actually my buddy did test the plugs that way a few times. I also found an exposed wire on one of the Engine Accessory Lead wires which was pretty close to the Igniter box.
 
1 - 7 of 7 Posts
Top