Kawasaki Motorcycle Forums banner
1 - 6 of 6 Posts

Registered
Joined
10 Posts
Discussion Starter · #1 ·
I recently (and stupidly) bought a 97 ZL600B Eliminator with lots of issues.
When I pressed the start button, the starter kept going and going until the battery died. The off switch mounted above the start button did not kill the starter.
Any ideas what could be wrong or where I should start to diagnose the problem?
Thx!
 

Administrator
Joined
4,455 Posts
You bought a 25 year old bike and are complaining about issues? 馃榿
In my world if a 25 year old bike did not have problems, I would be amazed.

Did the start button stay jammed down or did it pop back out?

Even if it popped back out, there is a good chance that the corroded contacts inside the switch welded themselves shut.
Take the switch apart and have a good look. You may be able to clean it up and make it work again.
 

Registered
Joined
180 Posts
Normally the kill switch is inline with the start button, so it would have stopped running with the kill switch. I would look at the start solenoid. If it sticks together it is a direct connection from the battery to the starter. Trace the large red wire from the battery to the solenoid. It then goes to the starter.
 

Administrator
Joined
4,455 Posts
Normally the kill switch is inline with the start button, so it would have stopped running with the kill switch. I would look at the start solenoid. If it sticks together it is a direct connection from the battery to the starter. Trace the large red wire from the battery to the solenoid. It then goes to the starter.
Right you are. Good catch of my mistake. I was going to suggest the solenoid as the next thing to check, when it obviously should have been the first thing to check.
 
1 - 6 of 6 Posts
Top