Kawasaki Motorcycle Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
I have owned this bike a year, and it has from what I have seen Full Muzzy Exhaust, Stage 1 jet kit, K&N air filter, I just installed a 525 JT Sprocket Quick accel kit with new chain...Just recently I have noticed sitting at the recommended idle range my bike like skips a beat and rpms kinda drop and it acts like it wants to stall, now I noticed the other day when sitting Idle my tach needle is jumping around not huge but noticeable to me....my first guess is something with the carb/air system maybe isn't sealed good enough. I know the valves on bikes need to be adjusted and buying this used I have no clue when the last maintainence was and if those were adjusted. Any help would be nice and well appreciated. Thank you!
 

·
ZX9R E1
Joined
·
274 Posts
I normally find that behavior at idle is a sign of a weak mixture, so yes it could be a leaking seal or the mixture may just need richening up slightly. But if you know the valves need doing i would sort that first before changing other settings.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
Well I don't know if the valves really need to be done or not until I tear it apart and see where they are at. Now I never did anything as far as work other then oil changes/air filter service since I have had the bike, what wouldn't be sealing good the carb boots? Also there should be an adjusting screw for the lean/rich ratio correct? I would assume I would need to do this adjustment with the bike running in idle in order to get it to idle properly? Thank you, any and all help is well appreciated =D
 
1 - 3 of 3 Posts
Top