Kawasaki Motorcycle Forums banner

1 - 18 of 18 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i need the wiring diagrams for a klf 300 :mrgreen: jumping it it will run until you take the cables off the battery. have the hotwire ran straight fromthe battery to the coil.
 

·
Registered
Joined
·
34 Posts
mr351clevland

gday mate i own a klf 300 4x4 ive hade the same problem with myn if i wer you id take that wire of that you have hot wired and check the plug on you rectifier it will be curoded and dirty its a common falt with em if that dont work try taking your rectifier off of the frame and just try it then
ahh any way i can give you a few wire coulers 4 it the main wire harnes power wire is white thats positive on ya batt the 2 ignition wires are white and brown and the coil is green and yellow i hope that helps ya let me know how ya go eddie
 

·
Registered
Joined
·
3 Posts
Hi ive got similar problems, somebody tried to rewire my klf 300 but made a cods head of itnow it doesn't spark.If you find wiring diagram I would appreciate a copy.
B&QMAGOO NEW MEMBER
 

·
Registered
Joined
·
34 Posts
klf 300 wiring

gday mate i cant give you wiring diagrame but i can tell you what you need to know to get it sparking again ahhh first of all up the front under your handlebars you will have 2 wires going to your igntion switch thes 2 wires are brown and white be carful because there are 2 brown wires there 1 is igntion switch the other is your horn now back up at your battery you need at least 1 white wire going to positive and at least 1 black wire with a yellow trace going to negative thats on ya battery just make shure the fuse isent blown on that white wire it dosent hurt to run more earths as i sed they are the black with yellow trace ok thats all you need on the batt appart from your starter motor leads of corse the 2 wires going to your coil should be yellow with a red trace and a green with a white trace if all steps are followed you should now have a green nutrel light and it should go if not try joining the 2 igntion wires together to rule out a falty switch and check your nutrel balb the 2 wires on your starter solinid are black and black with a yellow trace the other plugs are straight forward the cdi starter realay rectifier by the way make shure the plug on your rectifier isent dirty or curoded that should get you going let me know how you go if i can give any other help i will no problem
 

·
Registered
Joined
·
4 Posts
thanks mr351clevland,your a life saver, the black with yellow was not tied to ground, hooked up a jumper, cranked and ran perfect. At least it has a clean carb and all new electronics now. But now that it has sat up so long it wont shift out of nuetral, any ideas?
 

·
Registered
Joined
·
34 Posts
mate id say its just grown on the shaft ther wer it goes in to the casing just pop out the seil and give a spray with wd40 and just work it slowly it will go
 

·
Registered
Joined
·
3 Posts
gday mate i cant give you wiring diagrame but i can tell you what you need to know to get it sparking again ahhh first of all up the front under your handlebars you will have 2 wires going to your igntion switch thes 2 wires are brown and white be carful because there are 2 brown wires there 1 is igntion switch the other is your horn now back up at your battery you need at least 1 white wire going to positive and at least 1 black wire with a yellow trace going to negative thats on ya battery just make shure the fuse isent blown on that white wire it dosent hurt to run more earths as i sed they are the black with yellow trace ok thats all you need on the batt appart from your starter motor leads of corse the 2 wires going to your coil should be yellow with a red trace and a green with a white trace if all steps are followed you should now have a green nutrel light and it should go if not try joining the 2 igntion wires together to rule out a falty switch and check your nutrel balb the 2 wires on your starter solinid are black and black with a yellow trace the other plugs are straight forward the cdi starter realay rectifier by the way make shure the plug on your rectifier isent dirty or curoded that should get you going let me know how you go if i can give any other help i will no problem
Thanks Mr. C. On mine there are two sets of wires coming from the crank case, I presume one is from the pickup , is the other from the neutral switch?
 

·
Registered
Joined
·
1 Posts
Hello,
I am having the same problem.Was running fine, then all of the sudden no neutrel or reverse lights come on. Headlights are bright. Will not start by hand either. What did you do to correct the problem. All my wires look good. Thanks
 

·
Registered
Joined
·
34 Posts
klf wiring

hi mate sounds to me like you have a blown fuse on the batt you have a whitie wire on you posative it goes in to a little fuse holder check that it should be the prob
 

·
Registered
Joined
·
3 Posts
Hello,
I am having the same problem.Was running fine, then all of the sudden no neutrel or reverse lights come on. Headlights are bright. Will not start by hand either. What did you do to correct the problem. All my wires look good. Thanks
Hello,
I bought a book by CLYMER KLF 300 it has wiring diagrams and testing procedures for electrical components.
It turned out I needed a new igniter, which I paid £182 for from Electrexworld and it now runs fine.
I have read on this site that somebody used a CDI unit from a car, but I can't find it now.
Hope you get sorted.
 

·
Registered
Joined
·
7 Posts
Howdy, am running a KLF300c 4x4 about '92ish. Can anyone tell me what the 3 yellow wires coming out of the crankcase are. I'm guessing from whats already been posted they're not the reverse or nuertal switches or alternator pickup, so what does that leave.
Any help much appreciated.
 

·
Registered
Joined
·
1 Posts
mr351clevland

gday mate i own a klf 300 4x4 ive hade the same problem with myn if i wer you id take that wire of that you have hot wired and check the plug on you rectifier it will be curoded and dirty its a common falt with em if that dont work try taking your rectifier off of the frame and just try it then
ahh any way i can give you a few wire coulers 4 it the main wire harnes power wire is white thats positive on ya batt the 2 ignition wires are white and brown and the coil is green and yellow i hope that helps ya let me know how ya go eddie
klf wiring

hi mate sounds to me like you have a blown fuse on the batt you have a whitie wire on you posative it goes in to a little fuse holder check that it should be the prob
hey I might be having same problem no spark I’ve done bought all new electrical parts and still nothing I do have a black and yellow wire disconnected near air filter and also brown one is disconnected any idea
 

·
Registered
Joined
·
6 Posts
thanks mr351clevland,your a life saver, the black with yellow was not tied to ground, hooked up a jumper, cranked and ran perfect. At least it has a clean carb and all new electronics now. But now that it has sat up so long it wont shift out of nuetral, any ideas?
Im having the same problem with my 1986 Bayou. Replaced everything I can think of and it still has no spark after it was running great. SMFH.
 
1 - 18 of 18 Posts
Top