Kawasaki Motorcycle Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I have a problem with the Shifter Switch or Timing on my Bayou KLF-300-B2.

Every time I get on to start it, the situation is different. I 1st bought a New (very good) battery, to help with the Spark, because it will not Start with the Electric Start unless it is warmed up.

Here is my process; I turn on the fuel, turn the key on, I verify that it is in Neutral by the light, I turn on the choke, then I press the Electric Start to get fuel to the Carb. After all this I can usually start the ATV in 5 or less manual pulls. After it starts, I let it run for several minutes to get it warmed up & I'm riding.

Lately, it won't turn over by the Electric Starter, as though a safety switch has it off. I then put it in reverse and jerk it all over the place, which then allows it to start. Now it will turn over in 1st gear at times and will not turn over in neutral. When I do get it running it backfires a lot and does not run very well. I then try to put it in reverse, which at times is very difficult, I'll do a backwards donuts until it runs smooth and repeat if it starts to run OK.

I need help with this and where to take apart to fix. I'm thinking that there is something loose in the timing area. I really want to fix this because I've had it for 8 years and have gotten a lot of great riding out of it.

Thanks ahead for any tips you may have,
Bigdogtim7
 

·
Registered
Joined
·
3,787 Posts
You are shotgunning the problem and will spin your wheels until you approach the problem by isolating and ruling out each potential problem. It is really not possible to offer you a solution based on your description because of the approach you are using.

My recommendation is to pick up a service and repair manual and then follow the diagnostic steps outlined therein. That will put you on a path to be able to isolate the trouble.
 
1 - 2 of 2 Posts
Top