Kawasaki Motorcycle Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Well i am brand new to the site, thought i would join so i can see what everyone else has and does. I have a 1985 kx125...... am i the only one anyone else? would like to share info if so.
 

·
Registered
Joined
·
2,159 Posts
okay

Try the Kawasaki motocross and offroad section...I think tha tyou will be excited to find that there are several on board the FORUM with the KX125. Nice bike!
 

·
Registered
Joined
·
2,159 Posts
PROFILE

NOW besides the bike...fill in your profile for us...R U A barefoot skier? I can't do it. I'm to old now I could slalom and dip my elbows and roost water all over the place, even managed to pass in front of my own tow boat once or twice in my time...not smart...!
 

·
Registered
Joined
·
2,159 Posts
Triangle

spark (fire), gas (fuel), compression,,,then there is timing... get new plugs or you can't be sure of anything...then make sure you are getting gas to the carbs...can you smell any at the exhaust pipe after kicking it over several times,,,drain the carb bowl...do you have compresion my bet is on defective (carboned up plugs or no gas) most likely the problem...get NEW gas, and get NEW plugs...
 

·
Motorcycle Momma
Joined
·
839 Posts
Welcome

BlueLakebarefooter.

Welcome to the best cycle forum on earth!!!! :D We have lots of fun talking about bikes, riding and tech stuff. Part of the fun is diving into the different forums for interesting posts.

Hope to see you up here often!!! 8)

Keep the rubber side down!!!!

Heather
 

·
Motorcycle Momma
Joined
·
839 Posts
Mzdaspeed,

Welcome to the forum!!!!ZX-2R knows a lot about bikes, you can also go to the mechanics corner. There are a lot of cycle mechanics up here!!!!

Good luck getting it going..do you have a repair manual for it??? That is the first step to working on a bike.

Ride Safe/Ride Sane

Heather
 

·
Registered
Joined
·
7 Posts
no I changed the plug, the gas, the stator, the cdi, the coil, and the top end all in 2 days and could not get it started.

but I retract the last post because I got it STARTED TONIGHT!!!!!!


I do have one question. whats a good gas oil ratio for it?

the timing may still be a little off. Any real trick to that or is just by ear?


thanks for your post though i had a topic called Got problems with my obsolete kx125 that further explaind my situation.

anyways

THANKS


PATRICK
 
1 - 9 of 9 Posts
Top