Kawasaki Motorcycle Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
116 Posts
Discussion Starter #1
Just have had my 82 Spectre 1100 for 2 weeks and am dealing with minor electrical probs. This is a new one. Carbs are pouring gas out through the overflow tube. Bike runs ok, till warm, then hesitates on acceleration and bucks when letting go of the throttle. Backfires every once in a while. Any ideas?
Thanks
 

·
Motorcycle Momma
Joined
·
839 Posts
sorry on this too. It sounds like your floats are stuck open or are saturated. Check the carbs too ,may need cleaning and/or adjusting.

Welcome to the forum......lots of Spectre owners popping up!!!!

We had to clean the carbs, tank and replace the fuel lines on my Spectre. My mechanic adjusted the carbs and fixed the air/fuel mixture settings She ran 100% after that......


Clymers manuals are OK, but if you can find a Kawi manual, it is even better. Its worth the money to have one.


Keep us posted....drop us a PM anytime.

Heather
 

·
Registered
Joined
·
116 Posts
Discussion Starter #3
Thanks, Heather. Ill be taking them apart this weekend! Fortunately, it did come with the Clymers. Will look for the Kawi manual, though. The bike came without the airbox, so it shouldnt be too much trouble to get the carbs off. Have a good thanksgiving!

jono
 

·
Motorcycle Momma
Joined
·
839 Posts
Jono,

Have a Happy Thanksgiving also....Keep me posted on the Bike project!!!!

Heather
 

·
Registered
Joined
·
1 Posts
The problem with your carbs pouring out gas,could be that the diaframs are perferated.I own a 79 250 scorpion,as soon as the tank tap is open,gas floods out.Proberbly counts for the backfire as well as power loss due to fuel starvation..Good luck anyway
 

·
Registered
Joined
·
116 Posts
Discussion Starter #6
Thanks, My carbs have been a little finicky, but didnt have to strip them down, it seems that the float was that problem!

j
 

·
Registered
Joined
·
12 Posts
jono said:
Thanks, My carbs have been a little finicky, but didnt have to strip them down, it seems that the float was that problem!

j
how long was the bike sitting for?
 

·
Registered
Joined
·
116 Posts
Discussion Starter #8
The bike wasnt riden for a couple of years, the float happenned about a week after I got it on the road. My 78 had been sitting outside for what I figure was 10years! I took the carbs off and soaked them in Carb Cleaner and they worked like a charm!

j
 
1 - 8 of 8 Posts
Top