Kawasaki Motorcycle Forums banner

1 - 13 of 13 Posts

·
Winter sucks.
Joined
·
1,083 Posts
Discussion Starter · #1 ·
I bought this and installed it a couple of months ago, and 1/2 of the LED's died yesterday. Lovely product. I've read a number of accounts of the poor quality of the circuit board, and I apparently got a lemon, too.

I think I'm going to pull the clear lens off of it and put it on the stock base. I'll check into the warranty, but I don't think I want another one that will just fail again right away. I get to pull the fender to replace it as the 225/60R16 rear tire doesn't give me room to get my hands in there, even with it up on a lift. Fun fun.

FAIL.
 

·
BACK ON TWO WHEELS
Joined
·
13,542 Posts
wow, thats wierd, my clear alternatives lights on all three of my sport bikes were flawlesss. DId you check and see if loose wife.

BTW did you get the map i resent?!!?!?!?
 

·
Winter sucks.
Joined
·
1,083 Posts
Discussion Starter · #3 ·
I don't think a loose wife would affect it, but I can check for a loose wire. :D

I got the map. Thank you very much.
 

·
BACK ON TWO WHEELS
Joined
·
13,542 Posts
I don't think a loose wife would affect it, but I can check for a loose wire. :D

I got the map. Thank you very much.
sorry, loose wife...aka ex on the mind LOL


let me know how that map works for you
 

·
Winter sucks.
Joined
·
1,083 Posts
Discussion Starter · #5 ·
It seems OK so far. I got 36 MPG on the interstate yesterday with it, so that also is nice.
 

·
Registered
Joined
·
498 Posts
Mine failed in that any juice to the running light wire lights it up like the break light is on. I have tested it with a spare 12 volt battery with all the other wires disconeccted. It IS something on the mother board. I waited 10 Months to install mine, so after 3 Months, the year warranty was up. It looks great, but....

I have a ring of red leds in the clear turn signals that have running lights. I haven't been pulled over yet, for the main light not running, but I am waiting for it.

Herb
 

·
Winter sucks.
Joined
·
1,083 Posts
Discussion Starter · #7 ·
What ended up doing was removing the clear lens and putting it on the stock fixture with a red bulb. I put the CA light in the oven to melt the hot glue, and it came right off. The lens on the stock tail light was a huge PITA to remove, and, as it turns out, really can't be removed without destroying it (they use some pretty heavy duty rubberized glue on there that didn't soften up in the oven). It looks better with the red bulb and stock reflector, I think. The bulb was sort of tough to find, since it's an uncommon style anyway, but I found one at a local fast and furious type shop (spinners, body kits, neons, etc :p).

I figured that if I warrantied it out I'd just be in the same boat again shortly.
 

·
Super Moderator
Joined
·
10,876 Posts
I think you made the right choice by not going back with led's. I'm a fan of the clear lens/red bulb look.
 

·
Registered
Joined
·
498 Posts
What ended up doing was removing the clear lens and putting it on the stock fixture with a red bulb.
Well thank you. That is food for thought. Great idea.

Herb
 

·
Winter sucks.
Joined
·
1,083 Posts
Discussion Starter · #12 ·
Here's a cell phone pic, complete with my finger in the way:

 
1 - 13 of 13 Posts
Top