Kawasaki Motorcycle Forums banner

1 - 20 of 67 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter #1
I just purchased the MCV7400 gauge....

can anyone help with the wiring...

ie, which wires from the dakota goes where.....
 

·
Registered
Joined
·
4,807 Posts
If you go to the Dakota Digital website, there are install manuals there.
If you have any specific questions, post back.
 

·
Registered
Joined
·
180 Posts
Discussion Starter #4
yes I have the manual but is does not cross reference their wires with the wires from the meanstreak...there is one posted for harley...

example:

red wire from dakota goes to black wire from stock speed/tach harness..
 

·
Registered
Joined
·
4,807 Posts
If you have a wiring diagram for your bike, it probably could be cross-referenced, but it would be no easy feat. This insallation is going to require some major re-wiring.
What you could do is contact their tech support and see what they say.

I might be able to help with specifics, but to do the entire install over the internet would stretch both of our minds.

Post back with what you find out.
 

·
Registered
Joined
·
180 Posts
Discussion Starter #7
Can you post a wiring diagram for the gauges?
I spoke with dakota digital tech support and here is what they gave me. I did this but my FI indicator does not light up when key is turned on. my gauge powers up and my odometer and tach seem to be working fine but the speed/MPH does not work.

from left to right will be
-wire coming from dakota digital > wire coming from bike > explanation of what the function of the wire is.


red > red/blue - key on power -I was told to tap into the ignition switch gray,I tried this but gauge would not power up so I opted to tap into the running light for the front turn signal red/blue wire and now the gauge powers up (stock gauge)

white/red > white - power (from stock gauge)

black > black/yellow - ground (from stock gauge)

yellow > black or light green - tach signal (this taps into the front or rear ignition coil wire, you may need to extend this wire depending on how you route)

purple > red/black - high beam (taps into indicators on fuel tank cover assembly)

orange > green - left turn (taps into indicators on fuel tank cover assembly)

green > gray - right turn (taps into indicators on fuel tank cover assembly)

blue > black or light green - neutral indicator (taps into indicators on fuel tank assembly)

gray > blue/red - low oil pressure indicator (from stock gauge)

white/blue > red/yellow - FI light (from stock gauge)

white > light blue - output speed signal (need to connect here for auto turn cancelling to function (stock gauge)

brown > red/white - low fuel indicator (from stock gauge)

green > light green/red - sensor signal (from stock gauge)

red > light green/black - sensor power (from stock gauge)
 

·
Low Voltage High Current
Joined
·
217 Posts


This is the best I can do for now. So long as the wiring color codes remained the same for all 1600 Meanstreaks, this should help. I can probably post the pin-outs for the plugs in the head light bucket later, also. Sorry for the low quality screen shots, was just trying to get something up for others to help you out. I would take more time to help run down the individual wires you need, but cant do it today, maybe someone else can. Got to do the family Easter thing. I will check back later when I have time. Good luck!
 

·
Registered
Joined
·
4,807 Posts
The instruments should power up if you connect the red to your existing grey as that is a legitimate switched power source. I would investigate why this does not work. Who knows, maybe you are getting some kind of weird back circuit by not connecting at the grey. Maybe you have a problem with the wiring on the bike??
On second thought, tapping into the "brown" may be the best idea. The grey wire may have Kawasaki's anti-theft deely in it.

Post back.
 

·
Registered
Joined
·
180 Posts
Discussion Starter #11
would really appreciate if you could help with running down individual wires, when you have time...

thanks



This is the best I can do for now. So long as the wiring color codes remained the same for all 1600 Meanstreaks, this should help. I can probably post the pin-outs for the plugs in the head light bucket later, also. Sorry for the low quality screen shots, was just trying to get something up for others to help you out. I would take more time to help run down the individual wires you need, but cant do it today, maybe someone else can. Got to do the family Easter thing. I will check back later when I have time. Good luck!
 

·
Registered
Joined
·
180 Posts
Discussion Starter #12
The instruments should power up if you connect the red to your existing grey as that is a legitimate switched power source. I would investigate why this does not work. Who knows, maybe you are getting some kind of weird back circuit by not connecting at the grey. Maybe you have a problem with the wiring on the bike??
On second thought, tapping into the "brown" may be the best idea. The grey wire may have Kawasaki's anti-theft deely in it.

Post back.
which brown wire are you talking about.,
 

·
Registered
Joined
·
180 Posts
Discussion Starter #13
ok I wired up gauge per what I have above....gauge powers up when key on, and off when key off, tach, clock, low oil, FI, odometer (all working), speedo and gear indicators not working right. (turns, neutral, high beam not hooked up presently as I have those on my dash).

I guess I still need help with the wiring, seems like I am not getting proper signal for the speedo

here are some pics of how it looks:









 

·
Registered
Joined
·
180 Posts
Discussion Starter #15
If you look at the posted diagram, you will see a brown coming off of the ignition switch. That is the one. Do not use the grey.
is this my only option...right now I have the bulk of the wires running into the headlight housing like how the stock gauge wires ran....I have one wire that runs to the ignition coil (this is for the tach), so as much as possible I would like to keep most of the wiring in the headlight housing...looks for a cleaner install...

what do you think.
 

·
Registered
Joined
·
4,807 Posts
I would leave it for now and see if you can get the rest to work. Now, with the information that you have given, I do not see a power source to your speed sensor on the light green/ black. This is normally supplied from the stock unit. Is there one?
 

·
Registered
Joined
·
180 Posts
Discussion Starter #17
I would leave it for now and see if you can get the rest to work. Now, with the information that you have given, I do not see a power source to your speed sensor on the light green/ black. This is normally supplied from the stock unit. Is there one?
ok from the kawasaki manual above it looks like there are three wires for the

speed sensor stock: black/yellow is ground don't know what the other two are.
light green/red
light green/black
black/yellow

from the dakota unit there is a three wire harness ( I was told by digital dakota tech support to use on the green wire and connect to light green/red from stock gauge) so do I need to connect the other two wires from the dakota digital? if so where to I connect these too.
red - sensor power
green - sensor signal
black - sensor ground
 

·
Registered
Joined
·
4,807 Posts
Yes. Dakota red goes to Kawasaki harness light green/black.
Dakota green goes to Kawasaki harness light green/red.
Dakota black goes to Kawasaki harness black/yellow.
 

·
Registered
Joined
·
180 Posts
Discussion Starter #19
Yes. Dakota red goes to Kawasaki harness light green/black.
Dakota green goes to Kawasaki harness light green/red.
Dakota black goes to Kawasaki harness black/yellow.
ok I already have the black wire from the dakota digital going to the ground black/yellow in the headlight bucket, this black wire is the ground for the gauge. do I still need to ground this black wire from the dakota? if so where do I ground it to, like I said I already have the black wire from dakota grounded to the black/yellow?
 

·
Registered
Joined
·
180 Posts
Discussion Starter #20
can you also explain to me what the function of the stock wires are?

light green/red
light green black
 
1 - 20 of 67 Posts
Top