Kawasaki Motorcycle Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
My previous post detailed a smoking near the right side of my bike, after changing my oil and coolant it went away, later to reappear at which time i found the fuel hose had become disconnected from my fuel filter, fixed that and the smoking stopped NOW I was out monday night, was riding around a nice winding road ,in my lean, i was up to about 5 gear i was coming up on a light and pulled up and began my downshift..clutch..rolled off throttle..downshifting..the bike cuts off and would not come back on...i had a full tank of gas, my fuel cut-off switch was in the on position, my kick stand kill switch has long been disabled so that wasn't the cause, i took the tank slighly off and all hoses appeared connected couldn't see anything pinched to disturb gas delivery, i didnt check any fuses but what's the likelyhood a fuse blows while i'm riding??. I had this problem last summer and took it to a shop they ultimately replaced the battery, replaced fuel lines as well and i want to say cleaned the carbs. I recently had the fuel line replaced within the last two months, the battery has been fine since the shop replaced it, i had the fuel pump and ignition coils replaced within the last two months as well. I was told by the mechanic who replaced these items he also cleaned the carbs and jets..but he was suspect he couldn't figure out my headlight issue which i later figured out on my own so who knows what exactly he did honestly..BUT has anyone ran into similar occurrences, what could be preventing the bike from just starting back up?
 
1 - 2 of 2 Posts
Top