Kawasaki Motorcycle Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Has anyone else who installed the ds2-1 on thier 79 KZ1000 ltd b-3 had an issue with the rotor not fitting over the shaft? .... man that reads bad.
 

·
Obsessed by Z1's
Joined
·
520 Posts
Has anyone else who installed the ds2-1 on thier 79 KZ1000 ltd b-3 had an issue with the rotor not fitting over the shaft? .... man that reads bad.
Shaft? Are you trying to bolt the rotor directly to the end of the crank?

The bolt supplied with the ignition goes thru the rotor. The rotor sits inside the mechanical advancer arms - the advancer and rotor get bolted to the end of the crank.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Shaft? Are you trying to bolt the rotor directly to the end of the crank?

The bolt supplied with the ignition goes thru the rotor. The rotor sits inside the mechanical advancer arms - the advancer and rotor get bolted to the end of the crank.
lmao, yeah Jeff i was trying to put it on the crank shaft...lmao No bro not trying to put it on the crank shaft. I did however realize my mistake.
 

·
Registered
Joined
·
92 Posts
I've got a '79 B3 and I just picked up a used factory electronic ignition for it on Ebay but I haven't started to install it yet. I shouldn't have any problems (I hope) as it's a Kawasaki part.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Yeah, Once I realized that I was trying to put my new rotor over the oem rotor everything went pretty smooth. I had the entire project done the next day. If you have any questions while you are installing yours just let me know, I'll help you as much as I can.
 
1 - 7 of 7 Posts
Top