Kawasaki Motorcycle Forums banner

1 - 20 of 89 Posts

·
Registered
Joined
·
731 Posts
Discussion Starter · #1 ·
i got all my clutch problems sorted but still cant seem to work out why its revving up for those who havent read other posts my bike is a kx250 1996 ive checked everything on and around the carb theres no holes in anything the throttle is going right off its not sticky everythings tight but its still revving really hard when you start it and doesnt die down at all can anyone help me this bike is driving me insane
 

·
Registered
Joined
·
20 Posts
A friend and I were riding at a track once, I had my KX, he had his YZ and he went around a corner and his bike went insane, everytime he turned right his bike would rev up. His throttle cable was caught on a bit of the frame. Yours could be doing the same thing but being pulled even tighter, so it revs up all the time?

I know it's a long shot, but just check it.
 

·
Registered
Joined
·
731 Posts
Discussion Starter · #3 ·
ive tryed it with cable disconnected and its still revving anyone anymore ideas
 

·
Registered
Joined
·
731 Posts
Discussion Starter · #5 ·
it is closed completly ive checked all the simple things that i can think of
 

·
Registered
Joined
·
731 Posts
Discussion Starter · #7 ·
yeah cleaned it out 3 times and bought a new pilot jet still didnt make any differance at all
 

·
Registered
Joined
·
3,047 Posts
Did you inspect the reed valve gaskets, the cases, or the top gasket on the carb? Did you remove the boot between the carb and reed valve and check very thouroughly for cracks or tears?

-If there are no air leaks between the carb and the case, then you may have a blown right side crank seal. Take the magneto cover off and smell for gas.
 

·
Registered
Joined
·
731 Posts
Discussion Starter · #9 ·
i rebuilt the engine and put new seals in and was very careful in putting them in but will check it to make sure ive had everything of i even put a layer of silicone over the boot on the engine side and left it to dry guess ill just have to check it all again
 

·
Registered
Joined
·
731 Posts
Discussion Starter · #10 ·
just checked the seal took cover of and its stinking of gas dunno how but ill have to take engine apart again not happy will have to wait till next year now
 

·
Registered
Joined
·
731 Posts
Discussion Starter · #12 ·
it is yeah but it revs that hard i need to switch it of straight away so ive not been able get choke off my choke is really tight to pull out but has always been like this the bike is reving to more or less full revs on start up cant be good for it and i had a thought last night i spilt quite a lot of gas all over engine because i must have knocked the fuel valve on tank it ended up everywhere and my magneto cover wasnt tight so i think it could just be stinking because i spilt a lot why do u ask about choke
 

·
Registered
Joined
·
731 Posts
Discussion Starter · #16 ·
ive checked slide and everything i do stay near to a 2t garage but they charge a fortune for everything! y u ask??
 

·
Tree Magnet
Joined
·
393 Posts
if you haven't, check the carb/slide with it ON The bike. Look inside from the airboot side and make sure the slide is completely seated. you can turn the idle screw, while looking at the slide, and turn it all the way CCW (i believe) and make sure the needle and slide are all the way in there.
outside of this, I'm stumped without looking at it.
 

·
Registered
Joined
·
731 Posts
Discussion Starter · #18 ·
already done that to im stumped to i was thinking more about what yurfatmom said would the seal on the left case not have to be heavily damaged to let enough air in for it to rev to full throttle
 
1 - 20 of 89 Posts
Top