Kawasaki Motorcycle Forums banner

Has anyone put F &S engine guard on an 04 1600 classic

2519 Views 22 Replies 12 Participants Last post by  MK592
I bought one when I bought my bike, along with windshield and passenger backrest. I bought it from the deal and got the part# for my bike, when I got home I started installing and I'll all happy everything is bolting right up, no hassles, I'm glad I saved the guard for last because the lower bolts didn't fit through the holes in the guard, I was disappointed but not upset, took it back and brought the bolt with me to make sure it’ll go through the new one, nope exact same problem. They offered to drill out the hole and I told I could’ve done that at home and not drove 30 miles here, we checked another out of the box guard, and bolt still won’t fit. Service guy got involved and said he could drill it out with out messing up the chrome, I told him could do it but if he goofed it was their guard, success finally!!! I get home all happy and ready to go for a ride cause it wont take long to put it on, wouldn't you know the hole don't line up.... I can only get 3 lined up and the fourth is not even close. Now I was pissed and disgusted and haven't missed with it for 3 months now. Has anyone else had trouble like this? Someone told me it sounds like I got a guard for a 1500 classic but the part #’s are different.
1 - 1 of 23 Posts
I had the very same thing to happen when I installed my engine guard. Drilling out the holes a bit and then assisting the bolts with a rubber mallet.

It was a pain, but worth the results!

:D
1 - 1 of 23 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top