Kawasaki Motorcycle Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter #1
Here is the current situation:

I just purchased a 1990 Ninja 600r with a private owner with 13000 miles on it, 12467 to be exact. The bike starts up fine everytime. It also idles decently when the engine is cold. It is when the engine just up to normal temperature (needle is in the middle of the temp guage) that it has some trouble. If i just let it idle without touching the throttle it sometimes dies, not very often but it does happen. It just kinda stalls out on itself. Also when the engine is hot and when I give the throttle a good tug (this is when its in neutral and idling) it sometimes sputters. The rpms dont jump up right away.
Also when the engine is cold some white smokes comes from the exhaust when I give the throttle a tug. It goes away once the engine is somewhat warm. Is this normal?


Any idea how to fix this, because I dont think this is normal.

Thanks,
Sam
 

·
Registered
Joined
·
8,245 Posts
What color is the smoke that comes out when its cold?

I've been having random problems just like this with my '01 500R for months, just been going through things trying to figure out why its doing it.

I'd check

1. pilot jets (soak them)
2. float heights
3. vaccum lines
4. vaccum diaphram (in the petcock on the gastank)
 

·
Registered
Joined
·
132 Posts
Discussion Starter #3
Its white smoke that is coming out of the exhaust when the engine is cold. But is goes away once it warms up.


-Sam


Should I consider investing in a full tune up from a kawasaki dealership?
 

·
Registered
Joined
·
8,245 Posts
White smoke is okay, thats just moisture in the exhaust pipe.

I've considered taking mine to the dealer, but I have less than good faith in our local dealers and I'd prefer figure it out myself. I'm breaking my bike down as soon as I get a package with some new throttle cables in this week, hopefully I'll have an update.
 

·
Registered
Joined
·
132 Posts
Discussion Starter #5
But what about the sputtering with a crank the throttle when the engine is warm when idling? And whats the deal with the bike stalling every so often while idling. It idles around 900or so.


Sam
 

·
Registered
Joined
·
1,384 Posts
Pull your spark plugs as they may be fouled and need to be cleaned or replaced. Could be bad coils or wrong spark plug type as well. Make sure your battery is at spec as this can affect your bike as well.
 

·
Registered
Joined
·
605 Posts
yeah dude, it's just your idle screw, adjust it up a little bit so that it can always idle while in the mid temp without dying and you're set. plus it'll help warm it up a little bit quicker and make your engine last longer since you're not running down strips with a cold engine
 

·
Registered
Joined
·
12 Posts
I hate to bump an old thread, but i've been searching for a few minutes and I can't find information on where the idle screw is, I have an 90 ZX600C2. Anybody? Bueller? Bueller?


Thanks in advance.
 
1 - 9 of 9 Posts
Top