Kawasaki Motorcycle Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Greetings,

I have an 05 Meanstreak with Bub pipes, power commander & kurakyn hypercharger. Lately, I've had to use the choke (not sure if it's really a choke since the bike is fuel injected) to start and keep the bike running. It stalls and will not crank without slight pulling out on the choke. I changed the plugs yesterday and i'm still getting the same results. Any recommendations?

Thanks.

Smoove
 

·
Old Man Riding
Joined
·
930 Posts
It is not a choke as you stated. It is the idle adjustment.

Since you made those mods, I'm not sure what to recommend other than letting an experienced mechanic take a look.
 

·
Perpetual Motion
Joined
·
6,663 Posts
First try adjusting the idle adjustment (knob). My wife has a Meanstreak and I noticed that her idle setting seemed to wander a bit. I had to adjust it up twice since she purchased it.

Now that she has more miles on it, it doesn't seem to be an issue. Is yours relatively new?
 

·
Non Omnis Moriar
Joined
·
7,812 Posts
He may also be talking about the "high idle" adjustment which is found on FI bikes -my Nomad had one near the left front bottom of the engine on the frame.
 

·
Extreme Gizmologist
Joined
·
2,347 Posts
Any recommendations?
Well, since you're not showing any location information, we don't know where you're from. Is this problem related to the weather. My Meanie idles a lot differently in the cold weather now that I've stripped off all the emissions stuff -- Iv'e got a BAK installed. I just had to raise the idle setting. If the bike gets really warmed up, I have to lower the idle setting while I'm riding. It's not a huge difference, like maybe bringing 600 up to 900 and when its warm bringing 1200 down to 900.
 

·
Rebel Rider
Joined
·
3,646 Posts
Greetings,

I have an 05 Meanstreak with Bub pipes, power commander & kurakyn hypercharger. Lately, I've had to use the choke (not sure if it's really a choke since the bike is fuel injected) to start and keep the bike running. It stalls and will not crank without slight pulling out on the choke. I changed the plugs yesterday and i'm still getting the same results. Any recommendations?

Thanks.

Smoove

You're right, it's not a choke, but an enricher. All it does is set a higher idle to help with cold weather starts. The idle adjustment is the black knob
under the right side dog bowl. Turn it to the right to increase the idle. Make sure the engine is fully warmed up before setting the idle.

Could also be a problem with the power commander settings.
 

·
R.I.P. Deron Harden
Joined
·
2,698 Posts
You can also check your "zero throttle" position on the PCIII map. I adjust mine back to zero at least once a year.
 

·
Patriot Guardian
Joined
·
28,016 Posts
You're right, it's not a choke, but an enricher.
Not even an enricher... it just lifts the throttle body's high-idle cam.

Without the ICS (which were removed to install the Hypercharger), the "choke" will absolutely be needed for cold starts, and in many cases even that is not enough.

Gadget to the rescue!
Cold Idle Speed Fix
 
1 - 8 of 8 Posts
Top