Kawasaki Motorcycle Forums banner

1 - 13 of 13 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I've got a 2006 mean streak all stock with 2100 miles. The gas mileage stinks 20 mpg is all it gets. I don't beat on the bike. I took it to two dealers and both are telling me that nothing is wrong, that is all this bike gets. Kawasaki said it should get 35 mph and want me to try another dealer.
Does anyone have an Idea what could be wrong?
 

·
Extreme Gizmologist
Joined
·
2,347 Posts
Boy, something's wrong. My 2006 Meanie with 26K on it gets 35-42 mpg, depending how hard I twist the throttle.
2100 is really low mileage. Did you buy it used? I'd check to see if its got an aftermarket fuel processor with the settings drastically wrong. If it doesn't have the stock air intake and exhaust, odds are probably good that its got an aftermarket fuel processor installed.
The PCIII processor on my Mean Streak is plug and play and can be easily removed which is what I'd try first.

Any dealer service person telling you that 20 mgp is normal is lying.
 

·
Registered
Joined
·
9 Posts
If it's properly tuned, and the air cleaner is good, you should get way better then that.
Something I have noticed is that in using a high % enthanol gas, it usually gives you much less gas mileage?
I try to avoid those brands, but when the next better Gas Station is 100 miles away, I top off with whats available.
I ride mostly in groups ( Meetup.com) Many of our members ride 10 to 15 yr old bikes, for similiar problems I advise using amsoil PI ( Performance Improver) most average 5 to 7% better fuel economy.
 

·
Registered
Joined
·
11,328 Posts
Several things to check that might help in improving the gas mileage:

1.Proper tire pressure front and rear?
2.Drive belt/chain correctly tensioned?
3.Fresh set of properly gapped sparkplugs?
4.Air filter clean with no restricions?
5.Tried running some fuel sytem cleaner like Seafoam or Berrymans B-12?
6.Checked for dragging brakes?
 

·
Registered
Joined
·
9 Posts
The possibility of dragging brakes, could do that. Mine has been to the dealer 2X for that issue on the front brakes,
The first time it happened was only after 300 miles, & again after 1630 miles on a brand new Vulcan 900C.
At just under 7K it hasn't been an issue since.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Did buy it used. As far as I know the bike is completely stock. Tire pressure is good, no chain has shaft drive. Will take a good look at the brakes and fuel processor. Hoping I can find a dealer willing to listen since I bought a extended warranty, but so far unable to use it. Thanks for the help.
 

·
Registered
Joined
·
4,807 Posts
Unless you are pulling a barn behind you, it should do better than that.
Pull the spark plugs, then google "spark plug reading" and compare yours to what you see on one of the many web sites.


Post back with your results.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Front two plugs are normal and rear two are slightly rich. Checked gaps 3 at .030 and one at .032. Intake is clean and so is air filter.
 

·
Registered
Joined
·
4,807 Posts
Any aftermarket add-ons? Pipes, intake, etc?
Did you determine if it has a fuel processor?
How does it start hot/cold?
Any backfiring?
How does it idle hot/cold?
Any stumbling or flat spots on acceleration?
Any smoke whatsoever?
Any other driveability issues, no matter how minor or unrelated?
It will only go about 80 miles between fills?
Is the FI light on?
Do you ever smell gas at any time?

Post back.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
All stock, runs good, starts easy, no gas smell, 52 miles and light comes on takes 2.5 gallons, no issues other than a gas pig. I far found a dealer willing to check it out for $65.00 and give me an opinion.
 

·
Registered
Joined
·
9 Posts
Reading the all the posts I thought, perhaps since the mileage is very low for the year of the bike, It may have sat for long periods of time with older fuel is the tank.
You just might have enthenol issues.
there are several very good additives out there to clean up your system!
Best of luck at the dealership, I am hoping they don't charge you for the diagnostic time.
 

·
Registered
Joined
·
2 Posts
I would like JR to know the outcome of what ever happened to this bike. My bike is doing the exact same thing and cannot seem to find out what’s wrong. I was getting about 170 miles before my light came on. Now out of the blue I’m getting maybe 50 and my lights on. Please help me out.
 
1 - 13 of 13 Posts
Top