Kawasaki Motorcycle Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I need some help bad. I just purchased a used 2002 mule 3010. It’s in really great shape however I have been working on a brake problem for a few weeks now and I’m about to pull my hair out.
My problem is you have to apply the brake really hard to get stopped. I mean real hard. I have another mule, a 2001 - 3000 so I know what the brakes should be like.
Here is what I have done. I replaced the shoes and bleed the entire system multiple times. I removed the master cylinder and disassembled, seals and springs looked fine. There are no leaks that I can see anywhere. The pedal firms up like I would expect when I bleed the brakes and when applying constant pressure on the pedal, it does not continue to go down like an internal leak. I have checked the lines and they seem ok. I have flushed the entire brake system with new fluid, it’s as clear as water.. I have removed the drums many times and the wheel cylinders are not leaking and seem to be working ok.
The mule does not pull to one side when the brakes are applied either. Uggggggggh I have no idea. It’s like there isn’t enough pressure in the lines. I really don’t want to take it to the dealership but I’m about to give up… What am I missing here? Any help would be greatly appreciated..
 
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top