Kawasaki Motorcycle Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
HELLO, this is my first post...

i have a ZX10r with ~14000km on it, and it recently started acting funny.

whenever i go full throttle past 8000rpm, it accelerates, but in a very hesitant manner. if you roll of the throttle slightly, then it picks up speed faster than at full throttle.

it seems to be getting worse.

so far my local shop "hasnt found anything wrong"..but have replaced the spark plugs, done a complete tune-up, checked PARTS of the FI and electrical system, repaired the exhaust valve, changed the air temp sensor (made a huge improvement). BUT the problem is there.

anybody else heard or experienced this?

i need help, i am considering trading in my 10 if this problem isnt resolved.

thanks for your help...

Rod
Vancouver, BC, CANADA
 

·
Registered
Joined
·
41 Posts
Shouldnt your bike still be under warranty? Take it back to the dealer. Let them deal with the problem.
 

·
Registered
Joined
·
2,159 Posts
BEFORE

Before you jump in and take i to the shop, check your airfilter, clean it even if it looks clean...then take some water in a misting bottle and spray the entire area around the airbox, , wires etc, but do it at night...if it is electrical you will see some arcing...you mihgt also try some different plugs to solve the problem...sometimes they will crack teh ceramic inside or even get some carbon up inside nad your bike will act crazy. If you find the area where it seems to idle better then wait till the daylight and look very closely in that area...or at least tell the shop what you did and found...it may help them to id the problem...PLUGS an dcleaning the AIRFILTER is cheap...so is changing your gas station...This has been the result in several bikes especially lately...the gas manufactures have to guess at the weeather and make additive adjustments a month in advance sometimes...tyr a different brand of gas and let us know....
 
1 - 3 of 3 Posts
Top