Kawasaki Motorcycle Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
i have a kawasaki mule 1000 older model and just rebuilt carbs and have checked them numerous time float are set right, however when i push the accelerator it is bogging down as if it is not getting power??? the valve in the carb is fluttering when accelerator is applied do I need to change carb????
 

·
Registered
Joined
·
3,787 Posts
There are two things that cause carburetor air valve flutter, perforated diaphragm, or valves out of adjustment.

Do not waste your money on new carburetors unless the carb body itself is shot. Pick up the diaphragms if the problem remains after you adjust the valves.

You can see how they are build on kawasaki.com, just follow the owner info link to the parts diagrams.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
thanks

There are two things that cause carburetor air valve flutter, perforated diaphragm, or valves out of adjustment.

Do not waste your money on new carburetors unless the carb body itself is shot. Pick up the diaphragms if the problem remains after you adjust the valves.

You can see how they are build on kawasaki.com, just follow the owner info link to the parts diagrams.
I recheck all of the hoses and tightened them and checked the diaphragm and it was pinched it runs better may just be the age of the unit
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top