Kawasaki Motorcycle Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I'm new to the forum, and my 1995 Connie is new to me. This Connie looks practically new & shows 30,000 miles. What bothers me, is its rough idle. I have been told, that it is the "nature of the beast," and that all Connie's idle roughly. I'm also told, that this bike has had a recent dealer tune up, so a valve adjustment & carburator balance, plugs, etc., will not correct the rough idle.
Have I got a problem, or do they all idle roughly???:confused:
 

·
Thanks to all Veterans!!!
Joined
·
16,933 Posts
Welcome to the forums!!! Congrats on the new ride. I can't help you with the rough idle, but perhaps the question should be posed on the mechanics forum. They'll be SURE to be able to help.

Oh, by the way: you don't happen to have any pics, do you?
 

·
Missy Peregrym's #1 fan!
Joined
·
7,792 Posts
welcome and congrats!

pics are always appreciated!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
Thanks for the welcome posts. It's too cold to ride, and too cold to take a photo of my nice bike sitting in a junked/up garage. I had not noticed the "mechanical" forum; now my question has been reposted there.
 

·
Thanks to all Veterans!!!
Joined
·
16,933 Posts
Thanks for the welcome posts. It's too cold to ride, and too cold to take a photo of my nice bike sitting in a junked/up garage. I had not noticed the "mechanical" forum; now my question has been reposted there.
I saw that... you'll have a better chance of getting an answer there than you do here.
 

·
Spinach Eating Moderator
Joined
·
22,962 Posts
See my post in the Mech forum.
 
1 - 6 of 6 Posts
Top