Kawasaki Motorcycle Forums banner

1 - 7 of 7 Posts

·
but still a NooBie
Joined
·
1,104 Posts
Discussion Starter #1
First, I am not in love with technology. I want a cell phone that is...well, a cell phone. I have a camera. I don't need a phone with a camera. I don't text (though I would mind receiving a few "sext" messages). Technology is cool, but it is not the be-all and end-all of everything.

I bought a new 2008 Nomad. After the local dealer juiced the battery and added oil, gas, and they took a couple of rides on it, I picked it up last month with 16 miles on her. Exactly what I wanted.

However, it has some electronic gadgets on it. When I turn the key "on" there are three LCD (black) images that appear for a few seconds. An oil can (no pressure), a thermometer (water temp), and gasoline pump (think Exxon gas pump). When cranked, the oil can disappears, the thermometer disappears, but the gas pump does not disappear. According to the handbook, it checks the fuel system and should disappear within three seconds. It does not. It doesn't matter how much gasoline is in the tank, it does not disappear.

There are five black bars (LCD) that curve along the bottom of the screen which is the fuel gauge, but this is a gasoline pump (a la Exxon) that shows up and does not disappear. The low fuel yellow warning light is completely separate, and it works.

Does anyone else have this problem? I could take it to the dealer to get it fixed, but this might be some little glitch that doesn't amount to anything. And with the great weather we are having, I don't want to take her in. I have added two complete fill-ups since it appeared and it is still there. It appears to be running perfectly, over 700 miles so far, including nearly 300 since the gas pump first showed up.
 

·
Live to Ride
Joined
·
185 Posts
Old Dog, My bike does not have this guage. Take a drive to the dealership and have them explain what the guages mean and explain why it stays on.........it's under warranty if something is funky.
 

·
Registered
Joined
·
1,450 Posts
I'de disconnect the battery and see if everything re-sets, worth a try, but it will most likely have to go back to the dealer, my $.02
 

·
but still a NooBie
Joined
·
1,104 Posts
Discussion Starter #4
I have gone 280+ miles in the past two days, so I know that everything is working correctly. Someone else on another forum says that his will not go out, either, and that was a couple of years ago. :biggrin:

Sounds like "no worries" to me.

Thanks, guys.
 

·
2008 Nomad
Joined
·
37 Posts
Hi OlDog, I also have a 2008 Nomad and the gas pump light only comes on when the guage is on the last bar and not much fuel left in the tank. Hope this helps. Have fun and ride safe.
 

·
We need a Sarcasm Font!
Joined
·
3,864 Posts
You could always do like the Car Talk Guys recommend for "Idiot Lights" that don't mean anything and are just annoying.....

Put a piece of black electrical tape over it.
 

·
but still a NooBie
Joined
·
1,104 Posts
Discussion Starter #7
^^

My dad did that on the "check engine" light on his Toyota truck. That was some 15 years ago, and the truck is still running. :biggrin:
 
1 - 7 of 7 Posts
Top