Kawasaki Motorcycle Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi was wondering if someone might be able to help me...

recently my bike has been giving me the ****s... was all fine till one day i was riding, and then for some reason when ever i rev the engine to about 5000rpm (in first gear) it wont go any more even though i open the throttle to its fullest capacity... the grears still change but it just wont seems to rev any more after that...
A friend of mine had told me that it might be the carb... could be dirty and needs to be cleaned out???

Does anyone happen to have any ideas wot could be goin wrong, and possibly tell me wot i can do to fix it...

Thankyou in advance
Cosmo

PS. sorry if this has been asked b4 new to these forums .
 

·
AZ's Official Mechanic
Joined
·
5,201 Posts
could be carbs. get a manual and pull them down. clean out the jets and all passages with carb cleaner and COMPRESSED AIR. make sure you pull the idle circuit jets and main jets. run a small wire thru the PILOT JET and make sure its clean. (look thru it while holding it up to the light) also check to make sure the rubber diaphram in the top of the carb (hooked to the slide) moves smoothly by hand and returns. make sure it has NO rippes/tears etc.
good luck
 

·
Registered
Joined
·
65 Posts
Does the 5K rpm limit happen in every gear?

I had that problem with my bike, it would only rev up to 5 or 6K rpms in every gear no matter how much throttle I applied. I didn't know what it was and when I pulled the tank off and looked at the air cleaner I noticed the filter was not seated properly and there was a plug in the hole for my airbox. I removed the plug, placed the air filter in properly, and everything was fine after that.
 
1 - 3 of 3 Posts
Top