Kawasaki Motorcycle Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
what in the world is the problem, just got bak on my bike after a couple days, a 636 by the way...and the last time i rode it was a big storm i got caught in, heavy rain and wind, took it over to my gf's house cuz it was closest, but hopped on 'er today and the throttle was doin something weird, figured out what it was, it opens fine but when it comes to snappin' closed, it goes about 10 times slower than it should, which causes for some problems, but was still rideable. I know there is a accelerator cable and decelerator cable and where they are, don't "THINK" either of them came off but can't see where they lead down to...what do you guys think it could be? thanx in advance for all the help. Late.
 

·
Registered
Joined
·
1,384 Posts
Rust or bad adjustment. Re-oil the cable and check the adjustment.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #3 ·
Oh and i should mention it's an 04...RUST?? You think? how could that be? and what am i oiling these cables with and where exactly do i oil them? maybe i should take apart the handle and what not and see what's inside. Thanks. Anyone else?
 

·
AZ's Official Mechanic
Joined
·
5,201 Posts
i would make sure your GRIP is not draggin on the housing or the bar end weight. then i would loosen the screws a bit on the housing and see if it loosens up. and then i would pull the housing apart and lube up the inside. if you disconnect the cables pay attention to which goes where. (one is the pull one is the return), while you have it apart i would pull the bar end off and slide the whole twist grip off and put some lube inside before putting it back on the bar.
good luck
 

·
Registered
Joined
·
1,384 Posts
nik_z said:
Oh and i should mention it's an 04...RUST?? You think? how could that be? and what am i oiling these cables with and where exactly do i oil them? maybe i should take apart the handle and what not and see what's inside. Thanks. Anyone else?
If you get metal wet - it doesn't care if it was an 04 or not.... just a possibility though. Cable lube is available at your motorcycle shop and you would be oiling the top of the cable and letting gravity force the oil down the rest of the way to the bottom by hanging it vertical.

As Q mentioned it could be hung up on something or pinched.
 
1 - 5 of 5 Posts
Top