Kawasaki Motorcycle Forums banner

1 - 12 of 12 Posts

·
Steve
Joined
·
55 Posts
Discussion Starter #1
Has anyone had problems with your fuel gauge not working right on the v2k? Mine has been replaced once but less then 11 months has gone out again, and you have to replace the speedo head to repair it.

Thanks,
Steve
 

·
Registered
Joined
·
498 Posts
Yes. I can't find my prior posting, but my last 2 bars are always on, even if there is no fuel in the tank. At least the yellow light does come on when there is just a gallon remaining.

Herb
 

·
Winter sucks.
Joined
·
1,083 Posts
My only problem is mine goes down too fast! I think my right hand is the problem...
 

·
Vicrory is Mine
Joined
·
2,489 Posts
Had mine do the "two bar" thing a couple of times but it has always straightened itself out on the next tank of gas.
 

·
Steve
Joined
·
55 Posts
Discussion Starter #5
Mine is doing the two bar thing also, they have already replaced it once and now it's at my cost. Mine started it the 2nd time about a year ago and it hasn't started working again... Did either of you find out anything about it? or why it was doing that?

Thanks,
Steve
 

·
Live to Ride
Joined
·
185 Posts
I have been have the same problem intermitently. I actually emailed kawasaki about the problem and they came back with "this is within specs".
 

·
Registered
Joined
·
659 Posts
I never payed attention to fuel gauge I always reset the trip evey time I fill up.
 

·
You bought a WHAT?!!
Joined
·
1,503 Posts
I found out mine is painfully accurate. I had my bike shipped to 'Bama from Colorado, and they required the bike be near empty. The guage showed one bar and, at about the time I loaded the bike, the fuel light came on. Once I unloaded it in Alabama, I ran out of bars and fuel two blocks from the gas station. :mrgreen:

Like I said...painfully accurate.

On a more positive note...this thing runs like a scalded dawg at lower altitude!!!!
 
1 - 12 of 12 Posts
Top