Kawasaki Motorcycle Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
There is a throttle response delay on my 2003 Vulcan 1500 Classic. When I give it throttle, it hesitates for about a second before It goes. This happens on the initial end of each gear shift. Other than that, the bike runs fine.

More details: Bought bike used last year and it had the same issue. I just rode it w/the issue but it does not make for a smooth ride. Has 12k miles on it. It has a after market air intake, crankcase breather and straight V&H pipes.

Any thoughts on what could be causing the issue? Thank you.
 

·
Registered
Joined
·
1,295 Posts
Approximately how much does that cost?

$0 - $100?
$101 - $300?
more?
I think I got my Dyna Jet kit for like $40+ and just did it myself. The previous owner assured me it already had a jet kit, which it did, but I found it was done way wrong. If you are not mechanically inclined I really am not sure what a shop would charge.
 

·
Registered
Joined
·
1,295 Posts
p.s. You could try putting a stock filter housing on it, if you have a stock one, and see if that helps. If not I'd try the DynaJet kit #2167 for your bike.

Or it could even be a dirty carb or fuel filter.

I mean, it could be a lot of things but this is what it sounds like to me.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #6
Thank you again for the response. I tend to agree with you that it feels like a jetting issue. I've already run seafoam thru it and nothing has changed.
 

·
Registered
Joined
·
1,295 Posts
Thank you again for the response. I tend to agree with you that it feels like a jetting issue. I've already run seafoam thru it and nothing has changed.
Yeah I think if they did the intake and exhaust and no rejet that would do it. Take a look at the carb and if the metal cap is still over the mixture screw it was never rejetted.
 
1 - 7 of 7 Posts
Top