Kawasaki Motorcycle Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hello All, First of all i'd like to say hi, im Owen from South Wales, UK.

Basically I have been having problems with my old Zephyr 550. Just had the carbs re-balanced and oil changed as previously the engine filled up with petrol.

The problem after an initial few days of OK ish running the bike is back to its old tricks. The revs like to stick with the engine screaming before eventually stalling and dropping all the petrol over the road.

Does anyone experienced any similar problems before, am seriously going to start looking on ebay for a second set of carbs...as i believe 1 is sticking open?

Any help or nudges in the right direction are welcome, thanks
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
wow thanks for the quick reply.

As the carbs have been stripped several times already do you think it is worth buying new carb kits such as seals and o-rings. Im just concerned about spending more money if it will not help.
 

·
Registered
Joined
·
2,682 Posts
If you have stripped, cleaned & set the float heights correctly and the Carbs are still flooding then you would be advised to purchase a set of 4 new Float Valves at about £17.00 plus V.A.T. each from a Kwak dealer

You stand a chance of another set having the same problems..
 

·
Registered
Joined
·
1,512 Posts
If you have stripped, cleaned & set the float heights correctly and the Carbs are still flooding then you would be advised to purchase a set of 4 new Float Valves at about £17.00 plus V.A.T. each from a Kwak dealer

You stand a chance of another set having the same problems..
Make sure nothing is stuck in the float needle hole and that the float needles don't have a ring worn in the rubber. They should be a perfectly smooth cone.

bountyhunter has said he had some luck taking fine grit sandpaper to them to smooth them out, using a drill.
 

·
Registered
Joined
·
375 Posts
Hi and welcome to the forum, GREAT to ave another Zephyr owner in the mix, not many of us here in Canada. What year is the Zeph.

as for your carb issue, sounds like a stuck needle as the others mentioned. Best of luck with the fix.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Hello everyone, thanks for the replies,

Well i originally took off carbs and cleaned them myself to no avail. Next the garage stripped and balanced the carbs, the bike was running better but after a few days the rev's started shooting up and sticking....then the fuel drained all over road. The mechanic did say one of the carbs was 'worn'? and it was the best he could do.

To be honest i just want to get her running nicely without spending too much. Before i buy a new set of float valves is it possible to inspect the current ones just to make sure there the root of the problem, maybe take some photos?

Thanks again, shame really as she's now got a 12 month MOT....
 

·
Navy Vet Search & Rescue
Joined
·
8,842 Posts
Not sure what year your bike is but it probably has a vacuum petcock. If if does and you're dumping that much fuel then you have 2 failures. 1st is the petcock, which is supposed to cut off fuel flow when the engine is off. 2nd is the float valves or their adjustment. I've looked at a lot of valves over the years and have never seen that I could just look at and determine if it was failing or working properly. About the only thing you ever see is a ring around the needle where it makes contact with the seat and that will be present on working valves if they've been installed for a while.

If you do have a vacuum petcock, you might want to consider rebuilding it also and make sure you're not running it in the PRI position.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #10
Thank StarGate,

Yeah the bike's got a vacuum petcock. To be honest i was going to replace this after the carbs have been fixed. One - i didnt want to spend money if i cudnt fix the carbs and two - this allows me to test the results (though thinking about it i could just use prime on a new vacuum petcock...).

Ah well, does anyone recommend any good locations to source a new set of new float values in the uk...? Cheers
 

·
Registered
Joined
·
62 Posts
a bit late, but have u solved the leak?

I had similar problem with the pet-****: the spring that keeps the membrane closed when the engine is stopped was gone and the fuel was leaking down - as if you always prime the engine.

This has led to numerical stupid complications - some of which are documented:

https://www.youtube.com/watch?v=WfkuN_9dYQw

Now I have something similar to you - the revs remain high for a while after twisting the throttle; also sometimes it will just work o 3 cylinders - very annoying - or simply flooding...dont know exactly;
 

·
Registered
Joined
·
1 Posts
Hello everyone,

I just bought a Zephyr 550 and have the same problem: the revs are high then suddenly drop and the engine cuts off then it starts to leak petrol.
Did you find any sollutions?

Thank you!
 
1 - 12 of 12 Posts
Top