Kawasaki Motorcycle Forums banner
1 - 9 of 9 Posts

·
Registered
kawasaki zzr1400 2007
Joined
·
8 Posts
Discussion Starter · #1 ·
Hi, new to this forum, I have a 2007 zzr1400 and I have notice a vibration to the front every time I apply the front brake so I have changed the front brake pads hoping that the problem will go but didn't. I had a look to the roters but they look pretty good to me.
Has anyone ever had this kind of problem?
Thanks
 

·
Registered
kawasaki zzr1400 2007
Joined
·
8 Posts
Discussion Starter · #2 ·
Hi, new to this forum, I have a 2007 zzr1400 and I have notice a vibration to the front every time I apply the front brake so I have changed the front brake pads hoping that the problem will go but didn't. I had a look to the roters but they look pretty good to me.
Has anyone ever had this kind of problem?
Thanks
 

·
Registered
kawasaki zzr1400 2007
Joined
·
8 Posts
Discussion Starter · #3 ·
Hi, new to this forum, I have a 2007 zzr1400 and I have notice a vibration to the front every time I apply the front brake so I have changed the front brake pads hoping that the problem will go but didn't. I had a look to the roters but they look pretty good to me.
Has anyone ever had this kind of problem?
Thanks
 

·
Registered
kawasaki zzr1400 2007
Joined
·
8 Posts
Discussion Starter · #4 ·
Hi, new to this forum, I have a 2007 zzr1400 and I have notice a vibration to the front every time I apply the front brake so I have changed the front brake pads hoping that the problem will go but didn't. I had a look to the roters but they look pretty good to me.
Has anyone ever had this kind of problem?
Thanks
 

·
Registered
kawasaki zzr1400 2007
Joined
·
8 Posts
Discussion Starter · #5 ·
Hi new to this forum, a while ago I replaced the brake pads on my bike because of a annoying shaking/vibration every time I apply the front brake, thinking that that would be the end of the problem but unfortunately the same problem remain. I bled the system, checked he roters they seems to be good. Before I ll take bike to the mechanic I wanted to know if anyone has any ideas of what it could be.
Thanks
 

·
Registered
kawasaki zzr1400 2007
Joined
·
8 Posts
Discussion Starter · #6 ·
Hi new to this forum, a while ago I replaced the brake pads on my bike because of a annoying shaking/vibration every time I apply the front brake, thinking that that would be the end of the problem but unfortunately the same problem remain. I bled the system, checked he roters they seems to be good. Before I ll take bike to the mechanic I wanted to know if anyone has any ideas of what it could be.
Thanks
 

·
Registered
kawasaki zzr1400 2007
Joined
·
8 Posts
Discussion Starter · #7 ·
Hi new to this forum, a while ago I replaced the brake pads on my bike because of a annoying shaking/vibration every time I apply the front brake, thinking that that would be the end of the problem but unfortunately the same problem remain. I bled the system, checked he roters they seems to be good. Before I ll take bike to the mechanic I wanted to know if anyone has any ideas of what it could be.
Thanks
 

·
Super Moderator
Joined
·
11,053 Posts
Have you serviced your steering bearings lately? Or done any other maintenance on the front end? Replaced a tire maybe?
 
1 - 9 of 9 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top